Skip to main content
Samsung Developer Program

What version of Java does Galaxy Watch Designer require?

The version of Java required by the Galaxy Watch Designer (GWD) depends on the version of GWD you are installing and your operating system. GWD 1.6.2 or earlier for Windows supports only 32-bit versions of Java (version 8). GWD 1.7.0 for Windows and GWD 1.6.x for Mac supports 64-bit Java (version 8 or 11).

 

GWD Version Operating System Java SE Version1
8 11
32-bit (x86) 64-bit (x64)
1.7.0 Windows 32-bit2      
Windows 64-bit  

    

   

Mac  

    

   

1.6.x Windows 32-bit         
Windows 64-bit

    

   
Mac  

    

   

1.5.x and earlier Windows 32-bit         
Windows 64-bit

    

   
Mac

Older versions of GWD for Mac may require a specific version of Java. Please contact support for more information.

 

1Download Java SE from the Oracle Java Archive.
2GWD 1.7.0 does not support a 32-bit OS.

 

  • Was this article helpful?